Game actions are currently not processing correctly and the game may be temporarily down. We're investigating.

Incident Report for Pirate Nation

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 04:36 UTC

Update

We are continuing to investigate this issue.
Posted Apr 11, 2025 - 02:46 UTC

Investigating

Game actions are currently not processing correctly and the game may be temporarily down. We're investigating.
Posted Apr 11, 2025 - 02:46 UTC
This incident affected: Game Client.