The Buy button is not responding for players when clicked.

Incident Report for Pirate Nation

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 22:06 UTC

Identified

The team has identified the issue and is working on a fix right now. Listing is not impacted but players are not able to proceed with the purchase flow after clicking on the Buy button.
Posted Aug 19, 2025 - 21:47 UTC
This incident affected: Game Client and Marketplace.